Results 1 to 6 of 6

Thread: Electrical 2020 does not install correctly/completely.

  1. #1

    Join Date
    May 2020

    Electrical 2020 does not install correctly/completely.

    I am a new SolidWorks user and just installed the product yesterday. I had an error on the installation of the electrical product, but I did a repair and that, I thought anyway, was successful. However, when I try to run electrical I get the following error messages and I am not able to open any component libraries, etc., which I assume are stored in the SQL database.

    Anyone have the same problem or any ideas how to solve it?

    FYI - I am running this on Windows 10 at the latest revision on an iMac using Parallels.

    The first error message is:
    “Cannot connect to database. Please verify connection parameters:
    Database: tew_app_data
    Hostname: “my computer name”\TEW_SQLEXPRESS
    User ID: tew“

    The next error message is:
    “Database of projects is not opened. Verify your license or database version.”

  2. #2
    DNytes's Avatar
    Join Date
    Jan 2017

    SOLIDWORKS Electrical is the “cannot connect to database” error

    Yea I am having the same issue.

  3. #3

    Join Date
    May 2020
    Quote Originally Posted by DNytes View Post
    Yea I am having the same issue.
    I gave up on it. Researched it and tried what everyone said, but nothing worked for me. Too bad as it looked like an interesting product. Going to try TinyCAD instead.

  4. #4
    Eric Page's Avatar
    Join Date
    Jul 2011
    Toledo, WA
    If you're looking for something to make electrical system architecture drawings, I don't really have a good recommendation, but if you want to draw circuit schematics and do printed circuit board layouts, I can recommend DipTrace. I've been using it for years and found it to have a manageable learning curve. They offer a free hobbyist license that allows designs with up to 500 "pins" (a resistor, for example, has two pins) and boards with up to two signal layers and unlimited plane layers. I've only run into those limits once. Another very popular free electrical CAD package these days is KiCAD (pronounced key-cad). Both are under active development.
    Last edited by Eric Page; 02-12-2021 at 02:16 PM. Reason: Correct spelling.
    Eric Page
    Building: Kitfox 5 Safari | Rotax 912iS | Dynon HDX
    Member: EAA Lifetime, AOPA, ALPA
    ATP: AMEL | Comm: ASEL, Glider | ATCS: CTO
    Map of Landings

  5. #5
    I remember the install being a bit of a pain but you can get it working. For both Electrical and PCB make sure you have installed the "sever components" of these. I didn't and had to do that after the fact. I then was able to follow the guides explaining the "host location" part of the install

    Name:  Capture.JPG
Views: 922
Size:  83.0 KB

  6. #6

    Join Date
    May 2020
    Well, I tried Electrical again and finally appear to have succeeded. I say “appear” only because I have not yet tried to create and save a design, but at least the product installed with no errors and now runs.

    I tried several things over a three day odyssey and I wish I could say for sure which thing worked, but I am not 100% sure. I suspect the key was using the actual administrator account in Windows 10. I generally don’t use the Administrator account for normal work, but rather a personal account that does not have admin privileges. Normally, I can use the “Run with Admin privileges” option for things like installations and configuration, but that did not work with SolidWorks Electrical (it worked fine with everything else related to SolidWorks. I then gave the personal account admin privileges and that still did not work. I finally logged into the actual Adminstrator account and that worked, but then only after I went through and uninstalled all programs that had SQL in their name. So, being logged into the Administrator account and going into Control Panel/Programs and uninstalling everything SQL, I just ran the installation and it finally succeeded and Electrical fired up. Now to learn how to use it.

    Maybe somewhere it said to use the Administrator account, but I only recall seeing that you needed administrator privileges. It was the Goengineer web site that finally clued me in. They suggested that using the adminstrator account was the best way to get all of the access rights needed. I think this is needed only for the SQL installation and thus why everything else SolidWorks installs just fine from a personal account assuming you have admin privileges. This is what I followed to finally achieve success.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts